php5.2.17编译安装后添加XCACHE和OPENSSL支持

头一次编译安装php5.2.17,结果XCACHE和openssL没有添加,折腾了好久,终于成功,补上过程,方便查询:
系统是ubuntu 14.04,php5.2.17

请注意,我安装的php目录是/opt/source/php-5.2.17
Xcache编请注意,我安装的php目录是/opt/source/php-5.2.17译安装:
下载xcache

wget https://xcache.lighttpd.net/pub/Releases/3.2.0/xcache-3.2.0.tar.gz
tar zxvf xcache-3.2.0.tar.gz
cd xcache-3.2.0.tar.gzsudo /opt/source/php-5.2.17/bin/phpize
sudo ./configure --prefix=/opt/source/php-5.2.17/lib/php/extensions --with-php-config=/opt/source/php-5.2.17/bin/php-config --enable-xcache  
sudo make  
sudo make install

会生成xcache.so动态扩展文件,此文件的位置是
/opt/source/php-5.2.17/lib/php/extensions/no-debug-non-zts-20060613
编辑PHP.INI,载入这个动态扩展就可以了,需要将下载的源码包中的xcache.ini文件的内容添加到php.ini文件:
重新启动PHP-FPM即可:
sudo service php-fpm5217 restart
在源码包中还有htdocs目录,这个是WEB管理界面,可以将其拷贝到WEB目录中

安装OPENSSL

php5.2.17源目录ext目录中有OPENSLL的源码,只是在编译时忘记添加了,所以也是使用phpize来编译添加即可
请注意,我安装的php目录是/opt/source/php-5.2.17

cd /opt/source/php-5.2.17/ext/openssl
sudo /opt/source/php-5.2.17/bin/phpize

结果提示没有找到config.m4文件,源目录中的文件名不一致:

sudo cp config0.m4 config.m4

编译openssl

sudo /opt/source/php-5.2.17/bin/phpize
sudo ./configure --prefix=/opt/source/php-5.2.17/lib/php/extensions --with-php-config=/opt/source/php-5.2.17/bin/php-config --with-openssl
sudo make
sudo make install 

生成的openssl.so动态扩展文件还是位于/opt/source/php-5.2.17/lib/php/extensions/no-debug-non-zts-20060613
在php.ini文件中添加 openssl扩展,重启php-fpm,就可以看到php-info中已经添加SSL支持:


OpenSSL support enabled
OpenSSL Version OpenSSL 1.0.1f 6 Jan 2014

shuxin

发表评论

电子邮件地址不会被公开。 必填项已用*标注